下载Bootstrap

下载Bootstrap以获得编译的CSS和JavaScript,源代码,或将其包含在您喜欢的软件包管理器中,例如npm,RubyGems等。

编译的CSS和JS

下载适用于** Bootstrap v 4.4.1 **的即用型已编译代码,以轻松放入您的项目中,其中包括:

这不包括文档,源文件或任何可选的JavaScript依赖项 (jQuery and Popper.js).

下载Bootstrap

源文件

通过下载我们的源Sass,JavaScript和文档文件,使用您自己的资产管道编译Bootstrap。 此选项需要一些其他工具:

  • 用于编译CSS的Sass编译器(Libsass or Ruby Sass is supported)。
  • Autoprefixer for CSS vendor prefixing

如果您需要build tools,则可以使用它们来开发Bootstrap及其文档, 但它们可能不适合您的目的。

下载源文件

BootstrapCDN

使用BootstrapCDN 跳过下载,以将Bootstrap编译的CSS和JS的缓存版本提供给您的项目。

<link rel="stylesheet" href="https://stackpath.bootstrapcdn.com/bootstrap/4.4.1/css/bootstrap.min.css" integrity="sha384-Vkoo8x4CGsO3+Hhxv8T/Q5PaXtkKtu6ug5TOeNV6gBiFeWPGFN9MuhOf23Q9Ifjh" crossorigin="anonymous">
<script src="https://stackpath.bootstrapcdn.com/bootstrap/4.4.1/js/bootstrap.min.js" integrity="sha384-wfSDF2E50Y2D1uUdj0O3uMBJnjuUD4Ih7YwaYd1iqfktj0Uod8GCExl3Og8ifwB6" crossorigin="anonymous"></script>

如果您使用的是经过编译的JavaScript,请不要忘记在其之前包含CDN版本的jQuery和Popper.js。

<script src="https://code.jquery.com/jquery-3.4.1.slim.min.js" integrity="sha384-J6qa4849blE2+poT4WnyKhv5vZF5SrPo0iEjwBvKU7imGFAV0wwj1yYfoRSJoZ+n" crossorigin="anonymous"></script>
<script src="https://cdn.jsdelivr.net/npm/popper.js@1.16.0/dist/umd/popper.min.js" integrity="sha384-Q6E9RHvbIyZFJoft+2mJbHaEWldlvI9IOYy5n3zV9zzTtmI3UksdQRVvoxMfooAo" crossorigin="anonymous"></script>

软件包管理器

使用一些最受欢迎的软件包管理器,几乎将Bootstrap的“源文件”引入任何项目。 无论软件包管理器如何,Bootstrap都将需要Sass编译器和Autoprefixer,以进行与我们官方编译版本匹配的设置。

npm

使用the npm package在您的Node.js驱动的应用程序中安装Bootstrap:

npm install bootstrap

require('bootstrap')会将所有Bootstrap的jQuery插件加载到jQuery对象上。 bootstrap模块本身不导出任何内容。 您可以通过在软件包顶级目录下加载/js/*.js文件来分别手动加载Bootstrap的jQuery插件。

Bootstrap的package.json包含以下一些其他元数据:

  • sass - path to Bootstrap’s main Sass source file
  • style - path to Bootstrap’s non-minified CSS that’s been precompiled using the default settings (no customization)

yarn

使用the yarn package在您的Node.js驱动的应用程序中安装Bootstrap:

yarn add bootstrap

RubyGems

Bundler (recommended) 和 RubyGems 添加到您的Ruby应用程序中,在 Gemfile:

gem 'bootstrap', '~> 4.4.1'

另外,如果您不使用Bundler,则可以通过运行以下命令来安装gem:

gem install bootstrap -v 4.4.1

See the gem’s README for further details.

Composer

您还可以使用Composer安装和管理Bootstrap的Sass和JavaScript:

composer require twbs/bootstrap:4.4.1

NuGet

如果您使用.NET进行开发,则还可以安装和管理Bootstrap的CSSSass and和使用 NuGet 的JavaScript :

Install-Package bootstrap
Install-Package bootstrap.sass